gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 81 гостей онлайн
Вставить в таблицу Excel. Подстановочные знаки в Excel.

Подстановочные знаки в Excel.

      Можно в формулу Excel вставить символ, подстановочные знаки. Эти символы можно применить для поиска, в условном форматировании, др. Существую подстановочные знаки в Excel – это символы, которые обозначают определенные действия.
      Например, когда нужно найти в столбце слово в разных падежах (молоко, молоком, молоку, т.д.), то в пустой ячейке пишем такую формулу. Мы написали формулу в ячейке В5.
=СЧЁТЕСЛИ(A1:A10;"молок*")  Как написать формулу с функцией "СЧЕТЕСЛИ", читайте в статье "Функция "СЧЁТЕСЛИ" в Excеl". Нашлось таких 4 слова.
В формуле написали слово «молок» и поставили звездочку (*) – это значит, что Excel будет считать все ячейки со словами, которые начинаются на «молок», а дальше имеют разные окончания. 
      Символ «звездочка» в Excel (*) означает любой текст после слова, букв, которое мы написали в формуле перед звездочкой (например, "молок*").
      Можно сделать по-другому. В ячейке В2 написать «молок*». А в ячейке В5 написать такую формулу. =СЧЁТЕСЛИ(A1:A10;B2)  Получится так.
Символ Такой формулой можно выбрать весь товар из таблицы с одним названием и разными кодами (шуруп А1, шуруп 123, т.д.).      Ещё один подстановочный знак – это символ «Знак вопроса» в Excel (?). В формуле он означает один любой знак. Например, нам нужно найти все слова, которые начинаются с буквы «с» и заканчиваются на буквы «ла» (сЕла, сИла). В пустой ячейке (В4)  напишем такую формулу.  =СЧЁТЕСЛИ(A1:A10;"с?ла") Получится так.
Символ Или напишем искомое слово в ячейке В2 «с?ла», а в ячейке В5 напишем такую формулу.  =СЧЁТЕСЛИ(A1:A10;B2)О других способах применения подстановочных знаков читайте в статье "Примеры функции "СУММЕСЛИМН" в Excel".
      Как найти все слова с разными окончаниями в Excel.
Эти подстановочные знаки можно вставлять не только в формулы, но и в строку поиска в диалоговом окне «Найти» на закладке «Главная».
      Как выделить ячейки в Excel с похожими словами.
Использовать такие знаки можно и в условном форматировании.  Выделим диапазон. На закладке «Главная» нажимаем на кнопку функции «Условное форматирование». Выбираем функцию «Правила выделенных ячеек» -> «Текст содержит». Заполняем так.Нажимаем «ОК». Получилось так. 
Выделились все слова, в которых есть слово «шуруп».
      О других способах поиска в таблице Excel, читайте в статье "Поиск в Excel" тут.
Про других символы, что они означают, где применяются,  читайте в статье "Символы в формулах Excel".
      Какими способами можно сравнить данные с помощью диаграммы, смотрите в статье «Диаграмма в Excel план-факт».