gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 121 гостей онлайн
Возможности Excel. Выбрать сразу много данных из таблицы Excel.

Выбрать сразу много данных из таблицы Excel.

      Выбрать данные из таблицы может функция "ИНДЕКС" в Excel. Например, у нас есть таблица с перечнем товаров и ценой. Нам нужно выбрать по номеру заказа весь товар и цену, и внести все это в бланк заказа, в накладную, др.  И все это автоматически.
Таблица с перечнем товара такая.
Теперь нам нужно настроить таблицу Excel так, чтобы весь товар заказа № 1 вписался в бланк заказа.
 Для примера рядом с таблицей сделаем такой бланк.      Принцип работы такой.
Пишем в зеленой ячейке номер заказа и все товары из общей таблицы запишутся в бланке заказа автоматически.
В бланке заказа выделяем  диапазон ячеек  Е6:Е11, нажимаем кнопку равно (=)  и пишем такую формулу.
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B11;НАИМЕНЬШИЙ(ЕСЛИ($F$2=A2:A11;СТРОКА(B2:B11)-1;"");
СТРОКА()-5));"")
      Затем, для ввода формулы массива, нажимаем сочетание кнопок Ctrl+Shift+Enter.
      Пояснение к формуле.
Диапазон В2:В11 – это столбец с наименованием товаров  в таблице.
Ячейка F2 – в ней будем писать номер заказа.
Диапазон А2:А11 – это столбец в таблице товаров с номерами заказов.
      Далее в формуле написано СТРОКА(В2:В11)-1 – один, потому что от начала листа Excel, первая строка перечня товаров в нашей таблицы  находится на второй строке. Если бы начинался перечень товаров с третьей по счету строки, то мы бы поставили – минус 2. Смотрите пример ниже.
      Ещё в формуле написано СТРОКА()-5 – пять, п.ч. в бланке заказа первая строка, куда записываются товары заказа, расположена в шестой по счету строке от начала листа Excel.
Получилось так.
Для примера, чтобы понять, как писать формулу, добавим выше шапки таблицы одну строку. Тогда формула будет писаться так.
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B11;НАИМЕНЬШИЙ(ЕСЛИ($F$2=A2:A11;СТРОКА(B2:B11)-2;"");СТРОКА()-6));"")
      Теперь устанавливаем формулы в столбец  «Цена» бланка заказов. Формулу устанавливаем так же, но вместо диапазона столбца В2:В11 (наименование товара) пишем диапазон столбца С2:С11 (столбец «Цена»).  Получилась такая формула.
=ЕСЛИОШИБКА(ИНДЕКС(C2:$C11;НАИМЕНЬШИЙ(ЕСЛИ($F$2=A2:A11;СТРОКА(C2:C11)-1;"");СТРОКА()-5));"")
Получилась такая таблица.
ВЫБРАТЬ СРАЗУ МНОГО ДАННЫХ ИЗ ТАБЛИЦЫ EXCEL.Теперь в бланке заказа можно установить другие формулы. Например – сумму, расчет скидки, суммы без скидки, добавить столбец количества, т.д. Можно сделать любую форму бланка.
      Как применить эту и другие функции Excel для заполнения бланка, читайте в статье "Как заполнить бланк в Excel" тут.
      Как написать в Excel формулу по скидкам, смотрите в статье "Найти в Excel несколько данных сразу".
Ещё один способ выбрать нужные данные из таблицы и перенести их в другие ячейки, в бланк, смотрите в статье "Найти и перенести данные в Excel".