gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 121 гостей онлайн
Возможности Excel. Как найти в Excel ячейку на пересечении строки и столбца.

Как найти в Excel ячейку на пересечении строки и столбца.

      Функция "ИНДЕКС" в Excel поможет найти в таблице данные по двум параметрам сразу и по строке, и по столбцу и перенести эти данные в другую таблицу (бланк).
      Например, у нас есть таблица списка товаров по разным филиалам магазина. Нам нужно выбрать - по какой цене продают хлеб в третьем филиале. Или, выбрать стоимость товара (панели, двери, стекла) в зависимости от ширины и высоты.
       У нас есть такая таблица.
В ячейке рядом с таблицей вводим формулу. У нас, в примере, в ячейку G5 вводим такую формулу.
=ЕСЛИОШИБКА(ИНДЕКС(B3:D7;ПОИСКПОЗ(G3;A3:A7;0);ПОИСКПОЗ(G4;B2:D2;0));"")
Получилось так.
Найти в таблице Excel по двум параметрам.В зеленые ячейки написали искомые данные, в ячейке G5 появился результат. 
В этом примере мы вводим точные данные для поиска, которые у нас в таблице. Но, часто поиски нужно вести по примерным данным. Например, покупают не ровно метр, а 86 см. В таком случае, формулу напишем по-другому.
У нас такая таблица.

В ячейку G14 пишем такую формулу.
=ИНДЕКС(B12:D14;ПОИСКПОЗ(G12;B11:D11;-1);ПОИСКПОЗ(G13;A12:A14;-1))
Теперь вводим  высоту и ширину товара. Получилось так.При высоте 23 и ширине 100 получилась цена, ближайшая к нашим стандартам  - 152р.
Эта формула находит ближайшие размеры покупаемого товара к нашим размерам в таблице. Размеры эти округляются. В примере высота 23 округлилась до 50. Здесь формула округлила в бОльшую сторону, т.ч. мы  в формуле написали – минус1(-1). Если мы в формуле вместо минус 1 напишем просто один (1), по формула будет округлять в меньшую сторону.
        Важно, чтобы в таблице с данными числа были отсортированы по всем строкам и столбцам:
        по возрастанию, если ставим в формуле 1;
        по уменьшению, если ставим в формуле -1.
О других вариантах поиска читайте в статье "Поиск в Excel".
В таблице Excel можно выбрать информацию сразу по нескольким наименованиям и заполнить ими бланк. Подробнее смотрите в статье "Выбрать сразу много данных из таблицы Excel".