gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 154 гостей онлайн
Возможности Excel. Сортировка в Excel формулой.

Сортировка в Excel формулой.

      Есть несколько способов, как сделать сортировку в Excel. Для этого есть функция в Excel «Сортировка и фильтр». Как сортировать с помощью этой функции, читайте в статье «Сортировка в Excel». Здесь рассмотрим, как настроить сортировку в Excel с помощью формул. Эта сортировка удобна тем, что при изменении данных в столбце, произойдет автоматическая сортировка в Excel новых данных.
      Рассмотрим два способа сортировки данных в таблице Excel с помощью формул.
      Первый способ.
      Сортировка в Excel по возрастанию.
Сортируем с помощью функций «НАИМЕНЬШИЙ» или «НАИБОЛЬШИЙ».
В ячейке В5 пишем такую формулу. =НАИМЕНЬШИЙ(A:A;СТРОКА(A1))
      Обратите внимание!
Хотя первая ячейка для сортировки находится в пятой строке таблицы (А5), в формуле пишем ячейку А1. Копируем ячейку вниз по столбцу. Получилось так. 
В столбце С установили формулу с функцией «НАИБОЛЬШИЙ».  =НАИБОЛЬШИЙ(A:A;СТРОКА(A1))
      Второй способ.
      Сортировка по алфавиту в Excel.
Если в столбце стоят не числа, а текст, например, фамилии, наименование товара, т.д., то используем формулу массива. Таблица такая.Выделяем столбец и присваиваем ему имя. Как это сделать, читайте в статье «Присвоить имя в Excel ячейке, диапазону, формуле» тут. Мы присвоили имя «Фамилии».
      В ячейке В1 пишем такую формулу.
=ИНДЕКС(Фамилии;ПОИСКПОЗ(НАИМЕНЬШИЙ(СЧЁТЕСЛИ(Фамилии;"<"&Фамилии);СТРОКА(1:1));СЧЁТЕСЛИ(Фамилии;"<"&Фамилии);0))
      Для ввода формулы нажимаем сочетание клавиш «Ctrl» + «Shift» + «Enter», п.ч. это формула массива. Копируем формулу вниз по столбцу. Получилось так.
      Если предполагается добавлять строки в таблицу, то можно сделать динамический диапазон столбца А. Смотрите статью «Чтобы размер таблицы Excel менялся автоматически». Тогда формулу массива в столбце В нужно будет чуть дополнить функцией. Формулу в ячейке В1 напишем такую.
=ЕСЛИОШИБКА(ИНДЕКС(Фамилии;ПОИСКПОЗ(НАИМЕНЬШИЙ(СЧЁТЕСЛИ(Фамилии;"<"&Фамилии);СТРОКА(1:1));СЧЁТЕСЛИ(Фамилии;"<"&Фамилии);0));''  '')
      И формулу протянуть вниз по столбцу чуть ниже последней строки таблицы.
      Если данные в таблице не сортируются по дате, значит не правильно написаны все или некоторые даты. Как правильно сортировать по датам, смотрите в статье "Сортировка по дате в Excel".