gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 116 гостей онлайн
Возможности Excel. Найти и перенести данные в Excel.

Найти и перенести данные в Excel.

      Функция «ПОИСКПОЗ» и функция «ИНДЕКС» в Excel помогут из большой таблицы выбрать нужные данные и записать их в других ячейках. Это может быть таблица с любыми данными (числа, слова, т.д.) – перечень сотрудников фирмы, перечень товара с его параметрами, телефонный справочник,т.д.
      Есть способ, как перенести данные из таблицы Excel в таблицу Word. Смотрите статью "Как перенести таблицу из Excel в Word".   Этот способ удобен тем, что нужная информация появляется в специальных ячейках и не нужно ее выискивать в таблице по строке, т.д.
      Итак, у нас есть огромная таблица с множеством строк и столбцов. Нам нужно выбрать конкретные данные из нескольких ячеек.Например, таблица такая, в таблице может быть больше столбцов и строк. Шапку таблицы можно закрепить. Читайте статью «Как закрепить строку в Excel и столбец» здесь.
В чистых ячейках листа, не в таблице,  устанавливаем формулы для поиска данных. Например, название фирмы и номера телефонов  главного бухгалтера и бухгалтерии. Мы сделали такую таблицу. 
В ячейке А7 будем писать название фирмы, по которой нам нужно найти номера телефонов главного бухгалтера и бухгалтерии. В ячейках В7 и С7 будут прописаны эти номера (в этих ячейках мы напишем формулы).
      Устанавливаем формулу в ячейке В7 (№ телефона гл. бухгалтера). Формулу можно просто написать словами, а можно вызвать эту функцию на закладке «Формулы» в разделе «Ссылки и массивы». В функции «ИНДЕКС» выбираем функцию «массив; номер_строки;номер_столбца». 
Итак, формула такая.  =ИНДЕКС($A$2:$K$3;ПОИСКПОЗ($A$7;A2:A3;0);10)
      Пояснение формулы.
$A$2:$K$3 – это диапазон нашей таблицы, в котором  нужно искать данные (без шапки таблицы).
$A$7 – это адрес ячейки, куда будем писать название фирмы, по которой ищем информацию.
A2:A3 – это диапазон столбца, в котором написано название этой фирмы (у нас – это первый столбец А).
0 (ноль) – это значит, искать в таблице точное совпадение записи из ячейки А7.
10 – это номер столбца  из диапазона таблицы, из которого нужно взять информацию,  которую мы ищем.
Получилось так.
Теперь устанавливаем формулу в ячейку С7 (№ телефона бухгалтерии). Формула такая.
=ИНДЕКС($A$2:$K$3;ПОИСКПОЗ($A$7;A2:A3;0);11)
Здесь изменили только в конце формулы номер столбца. Получилось так.
Найти и перенести в Excel.По такому принципу можно сделать больше ячеек для найденной информации, установить такие формулы в бланке.
      Теперь достаточно ввести в одну ячейку название фирмы и вся нужная информация выберется из строки и появится в отдельных ячейках (в одном месте), не нужно двигать большую таблицу, т.д.
      Можно настроить таблицу так, что при определенных условиях будет выделяться сразу вся строка. Читайте об этом в статье "Выделить всю строку по условию в Excel".