gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 202 гостей онлайн
Возможности Excel. Игра в Excel.

Игра в Excel.

      Сколько можно работать? Пора и отдохнуть. Создадим игру в Excel, чтобы поучиться работать в Excel, познакомиться с возможностями Excel, и, при случае, отдохнуть от дел и поиграть в игру. Эта игра имитирует игру «Бросить кости».
      Как сделать игру в Excel.
Мы подготовили для игры квадрат.
      В ячейке С2 пишем такую формулу.   =СЛУЧМЕЖДУ(1;6)
Для дальнейшей работы, на время, чтобы вам было понятнее, окрасим ячейки цветом так.      Выделяем ячейки квадрата, устанавливаем шрифт Wingdings. Мы в формулах будем писать большую английскую букву «I» (И). Эта буква при этом шрифте становится большой точкой.
      Кстати, как применить этот способ, чтобы сделать график в одной ячейке (очень удобный, наглядный), читайте в статье «График Excel в ячейке» тут.
      Продолжим создавать игру. В ячейках С3 и Е5 (зеленые) пишем такую формулу.
=ЕСЛИ(ИЛИ(C2=2;C2=3;C2=4;C2=5;C2=6);"l";"")
      Внимание!
При написании формулы в ячейке будут появляться значки, вместо формулы, п. ч. стоит шрифт Wingdings. Ставим в ячейке знак равно и переходим в строку формул, пишем формулу в строке формул.
      В ячейках С5 и Е3 (синие) пишем такие формулы.    =ЕСЛИ(ИЛИ(C2=4;C2=5;C2=6);"l";"")
      В ячейки С4 и Е4 (желтые) пишем такие формулы.  =ЕСЛИ(C2=6;"l";"")
У вас могут точки быть расположены по-другому.
      Далее, в ячейку D4 (красную) пишем такую формулу.  =ЕСЛИ(ИЛИ(C2=1;C2=3;C2=5);"l";"")
Всё, формулы вписали. Скопируем диапазон С2:Е5 в диапазон G2:I5. Оформим игровое поле. Получится так.      Мы сделали так:
В ячейках С2 и G2 установили зеленый цвет шрифта, чтобы на зеленом цвете фона не было видно чисел в этих ячейках. В ячейках игрового поля убрали цвет, чтобы хорошо было видно квадратики и точки.
      Для того, чтобы бросить кости (изменить положение точек в квадратиках), нажимаем клавишу F9.
      По желанию, можно сделать таблицу подсчета очков. Если сделать такую игру на двух ноутбуках, то можно играть (соревноваться) вдвоем, т.д.
      Дерзайте! Удачного отдыха!   ;- )
Прикол в том, что, если мы скопируем эту игру в соседние ячейки, то выпадать количество точек в ячейках будет разное.Игры в Excel.Так можно играть одному с виртуальным противником.
      Как можно окрасить ячейки таблицы, шрифт, в том числе и по условию, смотрите в статье "Применение цветных ячеек, шрифта в Excel".
      Как уменьшить ячейки таблицы, как распечатать всю таблицу на одной странице, т.д. читайте в статье "Как поменять размер таблицы Excel, весь перечень вариантов".