gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 143 гостей онлайн
Сделать, создать, установить в таблице Excel. Как сделать тест в Excel.

Как сделать тест в Excel.

      Создать тест в Excel можно просто. Нам поможет функция в Excel «ЕСЛИ». Чтобы понять функцию «ЕСЛИ», читайте статью «Функция «ЕСЛИ» в Excel».
      Как создать тест в Excel.
Ответы на вопросы теста будут выбирать из выпадающего списка. Как сделать выпадающий список, смотрите в статье «Выпадающий список в Excel». Для теста подойдет ещё проще вариант выпадающего списка. Читайте статью «Как сделать выпадающий список в Excel без списка».
      Итак, создание теста в Excel.
У нас есть таблица с вопросами в столбце А и выпадающими списками с вариантами ответов в столбце В.В столбце С пишем оценку выбранного ответа. В ячейке С2 пишем такую формулу. =ЕСЛИ(B2=60;5;0)
       Пояснение формулы: если в ячейке В2 стоит цифра «60», то – это правильный ответ, за него ставим «5 баллов». Если ответ не правильный, то поставить «0».
В ячейку В3 написали такую формулу. =ЕСЛИ(B3=30;5;0) Получилась такая таблица.Считаем сумму набранных баллов.  В последней ячейке столбца С устанавливаем формулу «Автосумма». Мы в ячейку С4 поставили формулу автосуммы. =СУММ(C2:C3)
Теперь нужно оценить результат теста в зависимости от количества полученных баллов. Например, оценивать будем по такой шкале.
      10 баллов – оценка «5»,
      5 баллов – оценка «3»,
      0 баллов — оценка «0».

В ячейку В4 пишем такую формулу.  =ЕСЛИ(C4=10;5;ЕСЛИ(C4>=5;3;ЕСЛИ(C4>=0;0)))
Получилась такая таблица.
Теперь оформим анкету, тест. Вставим ячейки для ФИО, других данных. Скроем столбец С. Выделим шрифтом, цветом, границей ячеек, др., разделы теста, результат теста, т.д. Получился такой тест.
Если поставим все ответы правильно, то получится такой результат теста.
Как сделать тет в Excel.Получился высший балл –«5».
В выпадающем списке можно поставить не только цифры, но и слова. Например – «Да» и «Нет». Или – «отлично», «хорошо», «удовлетворительно», неудовлетворительно». В следующем варианте в выпадающем списке стоят слова.Создание теста в Excel.Тогда в ячейке G16 напишем такую формулу. =ЕСЛИ(F16="Да";5;ЕСЛИ(F16="Нет";0))   Если в тесте ставят ответы не словами, а знаками, итог подвести, тоже, можно.
      Какими способами это сделать, смотрите в статье "Как объединить данные теста в ячейках в Excel".
      Можно в Excel сделать любую программу. Смотрите готовые программы в Excel в статье "Как создать программу в Excel".

Поиск по сайту

Подписка на рассылку

Подписывайтесь на рассылку и получайте актуальную информацию об обновлениях на ресурсе.