gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 70 гостей онлайн
Сделать, создать, установить в таблице Excel. Создание списка в Excel без повторов.

Создание списка в Excel без повторов.

      Когда делаем в Excel выпадающий список с большим списком, то нужно этот список составить без повторяющихся данных. Например, у нас есть список сотрудников. Фамилии повторяются. Нам нужно сделать список фамилий для выпадающего списка, фамилии в котором не будут повторяться. Для примера возьмем такой список.
      Сначала, можно сделать динамический список, т.е. если в список добавим в ячейки фамилии, то адрес диапазона автоматически увеличится и эта фамилия войдет в выпадающий список. Это нужно для того, чтобы не менять адрес диапазона выпадающего списка вручную.
      Как  сделать динамический диапазон в Excel, читайте в статье «Чтобы размер таблицы Excel менялся автоматически» тут
      Мы выделяем ячейки А2:А9. Для создания динамического диапазона, мы заполнили диалоговое окно «Создание имени»  функции «Присвоить имя» на закладке «Формулы» так.
      Теперь в столбце В будем формировать список с уникальными, не повторяющимися фамилиями.  Для этого в ячейку В2 напишем такую формулу.
=ЕСЛИОШИБКА(ИНДЕКС(Фамилии;ПОИСКПОЗ(0;СЧЁТЕСЛИ($B1:$B1;Фамилии);0));"")
Это формула массива, п.э. нажимаем не просто «Enter», а сочетание клавиш «Ctrl» + «Shift» + «Enter». У формулы появятся фигурные скобки.
Копируем формулу по столбцу. Получился такой список с уникальными фамилиями. 
Создание списка в Excel без повторов.Теперь его можно использовать для создания выпадающего списка. Как сделать такой список, смотрите в статье «Связанный выпадающий список в Excel по алфавиту».
      Другой способ создания уникальных данных в списке – это убрать дубликаты в имеющемся списке. Читайте об этом в статье «Как удалить дубли в Excel».  
      Как настроить Excel, чтобы при попытке ввести повторяющееся значение, выходило окно предупреждения об этом, смотрите в статье "Запретить вводить повторяющиеся значения в Excel" здесь.
      В Excel можно сделать любой тест для любой категории людей. (для школьников, для производства, для опроса, анкету, т.д.). Смотрите статью "Как сделать тест в Excel".