gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 144 гостей онлайн
Сделать, создать, установить в таблице Excel. Как в Excel сделать список из двух.

Как в Excel сделать список из двух.

      Списки в Excel помогут сделать многоуровневый раскрывающийся список в Excel. Для этого нужно объединить списки в Excel в один.  Как создать многоуровневый раскрывающийся список в Excel, читайте в статье «Выпадающий список в Excel».
      Например, нам нужно последовательно написать два списка Excel в один, не объединяя одинаковые слова,  как это делается при консолидации. Смотрите  в статье «Как объединить таблицы в Excel». 
Есть два списка - в столбце А и столбце В.
Сначала делаем именованные динамические диапазоны Excel из каждого столбца (списка). Как это сделать, смотрите в статье «Чтобы размер таблицы Excel менялся автоматически».
Мы создали два динамических диапазона. В диспетчере задач это видно.Теперь в ячейке С16 пишем такую формулу массива.
=ЕСЛИ(СТРОКА()-СТРОКА($C$15)>СЧЁТЗ(Иванов);ИНДЕКС(Васечкин;СТРОКА(C16)-СЧЁТЗ(Иванов)-СТРОКА($B$15));A16)
Нажимаем не просто «Enter», а сочетание клавиш «Ctrl» + « Shift» + «Enter», п.ч. это формула массива. Формула будет в фигурных скобках. Копируем формулу по столбцу. Получился такой список.
Как в Excel объединить списки.Как пронумеровать список, читайте в статье "Автонумерация в Excel".
      В Excel можно, не только, составить один список из нескольких, но и, определить пол человека по имени, т.д. Например, нам нужно составить общий список лиц из нескольких списков, узнать, сколько среди них женищин, мужчин. Какими способами определить пол человека в Excel, смотрите в статье "В Excel по имени определить пол".
      Можно написать одинаковый список в Excel сразу на нескольких листах, при этом, их не нужно копировать. О таком способе составления списков, читайте в статье "Как заполнить таблицу в Excel сразу на нескольких листах". 
      А если нужно один список сделать из нескольких списков (больше двух), то смотрите статью "Как создать один список в Excel из трёх и более".

Поиск по сайту

Подписка на рассылку

Подписывайтесь на рассылку и получайте актуальную информацию об обновлениях на ресурсе.