gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 59 гостей онлайн
Сделать, создать, установить в таблице Excel. Как заполнить бланк в Excel.

Как заполнить бланк в Excel.

      Настроить заполнение бланка в Excel можно с помощью формул. Функции «ИНДЕКС» и «ПОИСКПОЗ» в Excel помогут нам в этом. Во втором варианте рассмотрим, как сцепить слова из разных ячеек в одно предложение.
      Первый вариант.
      Заполнить товарную накладную в Excel.
Например, у нас есть большой список товаров. Нам нужно автоматически заполнить товарную накладную, взяв все данные для этого из огромного перечня товаров. Итак, у нас есть такая таблица с перечнем товара на листе книги Excel «Товар».Выделим таблицу (А2:Е6). Присвоим ей имя. Как присвоить имя, смотрите в статье «Присвоить имя в Excel ячейке, диапазону, формуле».
      Мы присвоили имя таблице такое – «Все_Товары».
В столбце А перечислены товары.  Наименование товаров не должно быть одинаковым. Можно ввести код товара, если у них одинаковое название.
      Чтобы правильно работала формула поиска нужного товара из списка, в ячейки столбца  А  установим правило проверки. Выделим  диапазон ячеек столбца А (А2:А6). Заходим на закладку «Данные». В разделе «Работа с данными» нажимаем на кнопку «Проверка данных».
      В появившемся диалоговом окне в строке «Тип данных» выбираем – «Другой». В строке «Формула:» пишем такую формулу. =ПОИСКПОЗ(A2;$A:$A;0)=СТРОКА(A2)  Диалоговое окно заполнили так.
Эта формула будет проверять, есть ли одинаковые названия товара. Можно  написать свой текст сообщения при неверном заполнении ячейки (смотрите другие закладки диалогового окна).  Нажимаем «ОК».
      Теперь, когда мы напишем слово, которое уже есть в столбце А (например, в ячейке А6 напишем слово «стол»), выйдет такое предупреждающее окно.
      Внимание!
Данные в это список нужно вносить вручную. Если копировать, то проверка данных не сработает, нарушится.
      Или можно настроить условное форматирование, чтобы окрашивались  ячейки с одинаковыми названиями товара. Читайте статью «Как выделить повторяющиеся значения в Excel».  
      На другом листе «Накладная» есть бланк товарной накладной.Скачать полный бланк товарной накладной можно в статье «Товарная накладная».
В накладной в ячейках столбца А будем писать название товара, и все данные по этому товару будут переноситься в другие ячейки накладной.
      Внимание!
Условием заполнения накладной является правильное написание товара в ячейках столбца А в накладной.  Для этого, сделаем выпадающий список. Как сделать выпадающий список, читайте в статье «Выпадающий список в Excel» тут.
      Если список товаров слишком большой для выпадающего списка, то можно сделать зависимый раскрывающийся список, в котором товар будет расположен на определенную букву алфавита. Как сделать такой список, смотрите в статье «Связанный выпадающий список в Excel по алфавиту» здесь.
      Итак, в ячейках столбца А сделали выпадающие списки.
Теперь в накладной в остальные  ячейки вставим формулы, которые будут искать данные в списке товаров и переносить их в накладную.
В ячейке C2 «Единица измерения» пишем формулу.  =ЕСЛИОШИБКА(ВПР(A2;Все_Товары;3;ЛОЖЬ);"")
В ячейку D2 «Цена» напишем формулу. =ЕСЛИОШИБКА(ВПР(A2;Все_Товары;4;ЛОЖЬ);"")
В ячейку Е2 «НДС» пишем формулу. =ЕСЛИОШИБКА(ВПР(A2;Все_Товары;5;ЛОЖЬ);"")
      Формулы одинаковые. В них меняем только номер столбца по счету из списка товаров. В ячейке С2 поставили номер столбца - 3, п.ч. в списке товаров на листе «Товар» единица измерения» стоит в третьем по счету столбце.
      Или можно написать формулы с функцией «ИНДЕКС». Функция «ИНДЕКС» может искать не только в первом левом столбце таблицы, как функция «ВПР». Формулы будут такие.
В ячейку C4 для поиска единицы измерения напишем такую формулу. =ИНДЕКС(Все_Товары;ПОИСКПОЗ(A4;Товары;0);3)
В ячейке D4 такая формула.  =ИНДЕКС(Все_Товары;ПОИСКПОЗ(A4;Товары;0);4)
В ячейке Е4  =ИНДЕКС(Все_Товары;ПОИСКПОЗ(A4;Товары;0);5)
      Копируем все формулы вниз по столбцам. Всё.  Накладная готова. Теперь, выбираем из выпадающего списка наименование товара, и все данные автоматически появляются в других ячейках накладной.Как заполнить бланк в Excel.Осталось написать количество и установить формулу расчета стоимости товара с НДС. Как можно написать формулу по расчету НДС, читайте в статье «Присвоить имя в Excel ячейке, диапазону, формуле». Ссылка размещена в начале статьи.
      Эту функцию можно применить при создании прайс-листа. Как его сделать, смотрите в статье "Как сделать прайс-лист в Excel" здесь.
      Второй вариант.
Если нужно написать предложение из данных нескольких ячеек, то применим функцию "СЦЕПИТЬ". Как использовать эту функцию, читайте в статье "Функция "Сцепить" в Excel" тут.
      В бланке в ячейках для заполнения можно установить проверку вводимых данных, чтобы заполняли бланки верно и не было ошибок при обработке этих данных. Смотрите статью "Проверка данных в Excel".
    В Excel можно не только выделить или удалить повторяющиеся значения, но и сложить их перед удалением. Смотрите описание нескольких способов в статье "Как сложить и удалить дубли в Excel".