gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 142 гостей онлайн
Как сделать в Excel. Сумма по условию Excel.

Сумма по условию Excel.

      Рассмотрим, как выбрать из большой таблицы конкретные данные и посчитать сумму по условию в Excel. Например, выбрать все покупки конкретного покупателя и посчитать общую сумму продаж по конкретным менеджерам.
      У нас такая таблица продаж.
Рядом нарисуем такую таблицу для итоговых данных.
      Первый вариант.
      Посчитать сумму в Excel, если несколько условий.
Посчитаем, на какую сумму продали товар менеджеры Иванов и Петров покупателю «Лента».
В ячейке G3 пишем такую формулу.   
{=СУММ(($A$2:$A$7="Лента")*($B$2:$B$7="Иванов")*$C$2:$C$7)}
      Это формула массива, п. э., для ввода формулы, нажимаем сочетание клавиш «Shift» + «Ctrl» + «Enter». Подробнее о таких формулах, смотрите в статье «Формулы массива Excel».
Получится так.
В формуле мы установили абсолютные ссылки, чтобы можно было копировать эту формулу. Про различные ссылки в формулах читайте в статье «Относительные и абсолютные ссылки в Excel» тут.
      Заполняем таблицу данными и формулами. Получится такая таблица с итоговыми данными.Так можно выбрать разные данные, меняя в формуле название покупателя и фамилию менеджера. Вместо названий и фамилий, можно установить коды, адрес ячейки с этими данными, т.д.
      В ячейке G4 мы написали такую формулу.  
{=СУММ(($A$2:$A$7="Лента")*($B$2:$B$7="Петров")*$C$2:$C$7)}
В этой формуле мы указали вместо названий и фамилий адреса ячеек.
{=СУММ(($A$2:$A$7=E3)*($B$2:$B$7=F3)*$C$2:$C$7)}
Таблицу можно сделать динамической. Смотрите статью «Чтобы размер таблицы Excel менялся автоматически» здесь.
      Второй вариант.
      Посчитать в Excel сумму определенных чисел.
Если нужно посчитать сумму всех продаж конкретного менеджера по всем покупателям сразу, где сумма за покупку составляет больше конкретного числа, то формулу напишем такую. Это формула массива.
{=СУММЕСЛИМН(C2:C7;B2:B7;"Иванов";C2:C7;">900")}
      Третий вариант.
      Посчитать сумму в Excel по условию – по одному слову из текста ячейки.
Например, в ячейках столбца B идет полное название товара, состоящее из нескольких слов, т.д.
Например, нам нужно выбрать со словом «детский».
У нас такая таблица.
В ячейке С24 мы написали такую формулу. 
=СУММЕСЛИ(B24:B28;"*детский*";A24:A28)
      По этой формуле Excel посчитал сумму из столбца А всех детских предметов из столбца В.
      В Excel есть много разных функций, которые мы можем вставить в таблицу - установить фильтр, сделать таблицу динамической, т.д. Но, есть специальная функция форматирования таблицы, которая автоматически устанавливает многие функции. Подробнее об этом способе создания таблицы, смотрите в статье "Форматировать как таблицу Excel".