gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 126 гостей онлайн
Как сделать в Excel. Функция "СУММЕСЛИ" в Excel, примеры.

Функция «СУММЕСЛИ» в Excel, примеры.

      Рассмотрим, как применять символы в формулах Excel, чтобы посчитать сумму по условию, выборочно. Символы в формулах помогают выбрать из таблицы конкретные данные. Как использовать функцию «СУММЕСЛИ», смотрите в статье "Функция «СУММЕСЛИ» в Excel".
      У нас такая таблица.
      Первый пример.
      Сумма ячеек с условием Excel.
Нам нужно посчитать сумму всех Ашанов. В ячейке С2 пишем такую формулу.
=СУММЕСЛИ(A2:A8;"*Ашан*";B2:B8)
      В формуле мы поставили по обе стороны от слова Ашан звездочки. Это значит, что нужно искать все слова «Ашан», не зависимо от других слов, цифр, которые написаны перед или после слова «Ашан» - Ашан, Ашан №3, Левый Ашан, т. д.
      Подробнее о символах, которые можно написать в формуле и что они означают, читайте в статье «Символы в формулах Excel» тут.
      Второй пример.
      Сумма выборочных ячеек Excel.
Нам нужно посчитать сумму всех Ашанов с номерами, у которых нет слов перед словом «Ашан».
В ячейке D4 напишем такую формулу.
=СУММЕСЛИ(A2:A8;D3&"*";B2:B8)
В формуле мы указали адрес ячейки, в которой написано «Ашан» и с содержимым этой ячейки сцепили (&) знак «*» (звездочка). Это значит, что формула будет искать в столбце А все слова «Ашан» независимо от того, что написано после слова «Ашан».
      В Excel можно сортировать данные одновременно по нескольким столбцам и строкам, по нескольким условиям. Как это сделать, смотрите в статье "Сортировка в Excel по нескольким столбцам и строкам".