gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 111 гостей онлайн
Как сделать в Excel. Как посчитать количество заполненных ячеек в Excel выборочно.

Как посчитать количество заполненных ячеек в Excel выборочно.

      Рассмотрим, как посчитать количество заполненных ячеек в Excel  по условию, как посчитать не все ячейки, а выборочно.
 У нас такая таблица.
Нам нужно посчитать количество заполненных ячеек по конкретному покупателю.
      Первый вариант.
В ячейке С2 пишем такую формулу. =СЧЁТЕСЛИМН(A2:A10;"Иванов АП";B2:B10;">0")
      Второй вариант.
В ячейке D2 пишем такую формулу. =СУММПРОИЗВ(((A2:A10)="Иванов АП")*((B2:B10)>0)*1)
      Чтобы узнать количество заполненных ячеек по другому покупателю, пишем его фамилию и инициалы в формуле.
Мы написали так. =СЧЁТЕСЛИМН(A3:A11;"Петров ИС";B3:B11;">0")
Получилось так.Можно в формуле написать не только фамилию, а название фирмы, код, т. д., то, что написано в столбце.В ячейке D2 мы написали такую формулу.
=СЧЁТЕСЛИМН(A2:A7;"Лента";C2:C7;">0")
      Можно в формуле указать ссылку на конкретную ячейку, в которой будем писать нужную фамилию, чтобы узнать количество заполненных ячеек.
      Другие формулы для подсчета суммы ячеек с разными условиями, смотрите в статье «Функция «СЧЁТЕСЛИ» в Excel».
      В Excel есть много функций суммирования выборочных данных. В формулах можно применять специальные символы, чтобы выбрать определенные данные. Как это сделать, смотрите в статье "Функция "СУММЕСЛИ" в Excel, примеры".