gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 85 гостей онлайн
Поменять, закрепить, развернуть в таблице Excel. Как заменить в Excel отрицательное число на ноль.

Как заменить в Excel отрицательное число на ноль.

      Можно в Excel заменить цифру, значение на ноль, в т.ч. отрицательное число. Настроить таблицу не отображать нули в Excel можно функцией условного  форматирования, заменить ноль на тире, т.д.  Смотрите статью «Как убрать нули в Excel».
Здесь рассмотрим три варианта, как заменить в Excel отрицательное число на ноль.
      Первый вариант.
Функция «МАКС» в Excel.
Если нужно, преобразовать отрицательное число в ноль, нужно воспользоваться функцией «МАКС». У нас такая таблица.

Здесь из первого столбца А вычислили второй столбец В. Теперь нам нужно, чтобы в таблице Excel вместо отрицательных чисел стоял нуль.
В новом столбце (у нас в примере, в столбце D) пишем формулу. На закладке «Формулы» в разделе «Библиотека функций» выбираем «Другие функции». Затем выбираем функции «Статистические» и нажимаем на функцию «МАКС». Появилось диалоговое окно. Заполняем его.
В строке «Число 1» пишем формулу расчета. В строке  «число 2» пишем число, меньше которого не показывать в таблице. Получилось так.Нажимаем «ОК». Получилась такая формула  =МАКС(A2-B2;0)  Копируем формулу вниз по столбцу. Результат получился такой.

Как скрыть нули в Excel.

Этой функцией «МАКС»  можно выбрать наибольшую цифру в столбце или строке. Например, узнаем какая цифра самая большая в строке 2.  В ячейку E2 пишем такую формулу  =МАКС(A2:D2)  Получилось. 

      Второй вариант.
 Нам пригодится функция «ЕСЛИ» в ExcelЭта функция находится на закладке «Формулы», в разделе «Библиотека функций» выбираем – «Логические». Или просто пишем такую формулу в ячейке D2.  =ЕСЛИ(A2-B2<0;0;C2) Получилось так. 

      Третий вариант.
В новом столбце пишем формулу. В примере мы напишем формулу в ячейке F2.  =(C2>0)*C2  Результат такой.

      Как сложить только отрицательные, или только положительные числа, смотрите в статье «Сумма отрицательных чисел в Excel» здесь.
      Иногда, для автоматического составления отчета, нужно записать отрицательное число не с минусом, а в скобках. Как это сделать, читайте в статье "Отрицательные числа Excel в скобках".