gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 250 гостей онлайн
Поменять, закрепить, развернуть в таблице Excel. Как поменять местами столбцы в Excel.

Как поменять местами столбцы в Excel.

      Чтобы в таблице Excel перевернуть строку слева на право, перенести данные из последних ячеек  в первые, перевернуть таблицу в Excel по горизонтали, нужно использовать функции Excel.
       Например, есть таблица с большим списком с фамилией в первом столбце, а имя написано во втором столбце. Нам нужно переделать список, чтобы имя было написано в первом столбце, а фамилия во втором.
Есть несколько вариантов.
      Первый выриант.
У нас такая строка.

Нам нужно, чтобы в строке было написано : Пт, Чт, Ср, Вт, Пн. В ячейке А2 пишем такую формулу.
      =СМЕЩ($F1;;-СТОЛБЕЦ())
Копируем эту формулу вдоль строки. Получилось так.

Если скопируем эти формулы в строке, вниз по столбцам, то можно перевернуть всю таблицу, все строки. Получится так.

Как поменять местами столбцы в Excel.

      Второй вариант.
В ячейке А2 пишем  такую формулу.
=ИНДЕКС(1:1;;ЧИСЛСТОЛБ($A$1:$E$1))
В формуле:
      1:1 - это диапазон всей строки;
      $A$1:$E$1 - это диапазон строки в нашей таблице.
В ячейке В2 пишем такую же формулу, но добавляем «-СТОЛБЕЦ (А1)». Получилась такая формула.
=ИНДЕКС(1:1;;ЧИСЛСТОЛБ($A$1:$E$1)-СТОЛБЕЦ(A1))
Копируем эту формулу по строке. Получилась такая таблица.

      Третий вариант.
Пишем такую формулу в первой ячейке.
=ИНДЕКС($A6:$J6;;СЧЁТЗ($A6:$J6)-СТОЛБЕЦ()+1)
Копируем эту формулу по всей строке. Получилось.

Поменять местами столбцы в Excel.

Все формулы в строке можно скопировать на другие строки и развернуть таблицу в Excel.
      Можно в Excel поменять местами строки и столбцы, т.е. развернуть таблицу. Подробнее об этим, читайте в статье "Как поменять местами столбцы и строки в Excel".
      В большой таблице Excel можно удалить сразу много лишних пустых строк. Специальной функции нет, но можно воспользоваться другой функцией и применить небольшую хитрость. Как это сделать, смотрите в статье "Как удалить пустые строки в Excel".