gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 205 гостей онлайн
Поменять, закрепить, развернуть в таблице Excel. Месяц из даты Excel.

Месяц из даты Excel.

      Можно извлечь с помощью формул Excel из даты месяц, год, день. Как вставить текущую дату, смотрите в статье «Текущая дата в Excel» здесь. Как правильно настроить формат даты (не ячейки), чтобы формулы считали даты, смотрите в статье «Преобразовать дату в текст Excel».
Рассмотрим еще несколько приемов работы с датами в Excel.
      Извлечь месяц из даты Excel.
Например, в ячейке А1 стоит дата -  12.06.2016. Нам нужно извлечь из даты месяц.
      Первый вариант.
В ячейке В1 пишем такую формулу (формат в ячейке – «ДАТА»).   =МЕСЯЦ(А1)   Получится так.
Месяц из даты Excel.      Второй вариант.
Чтобы в ячейке В1 месяц был написан прописью, формулу напишем такую.
=ИНДЕКС({"январь";"февраль";"март";"апрель";"май";"июнь";"июль";"август";
"сентябрь";"октябрь";"ноябрь";"декабрь"};МЕСЯЦ(A1))
Получится так, смотрите ячейку В2.
      Извлечь год из даты Excel.
В ячейке С1 пишем такую формулу.  =ГОД(A1) Получится так.
      Извлечь число из даты в Excel.
В ячейке D1 пишем такую формулу.  =ДЕНЬ(A1) Получилось так.
      Как узнать в Excel количество дней в месяце.
Используем предыдущую таблицу с датой 12.06.2016. В ячейке А2 пишем такую формулу.
=ДЕНЬ(КОНМЕСЯЦА(A1;0))
Получилось так.
В июне месяце 30 дней.
      Как прибавить к дате дни, месяцы, года, смотрите в статье «Работа с датами в Excel».
Как соединить в одно предложение слова и даты из ячеек, смотрите в статье "Функция "СЦЕПИТЬ" в Excel".
      О других способах различных расчетов, вычислений дат, смотрите в разделе "Другие статьи по этой теме" в конце статей. 
     В Excel можно округлять числа несколькими способами. Но, иногда, нужно отключить округление чисел. Как это сделать, читайте в статье "Как убрать округление чисел в Excel".