gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 173 гостей онлайн
Формулы в Excel Сложить выборочно данные из таблицы Excel.

Сложить выборочно данные из таблицы Excel.

      Можно в Excel сложить выборочно данные из ячеек. Так можно посчитать, например, сумму товарного чека, т. д. У нас есть список товаров, в котором указаны заказчики. Нам нужно узнать, на какую сумму конкретный заказчик купил конкретный товар. У нас есть такая таблица.
Мы хотим узнать, сколько хлеба заказывал Иванов. В пустых ячейках заполняем другую табличку:
      В ячейке F1 пишем фамилию заказчика – «Иванов», в ячейке F2 пишем наименование товара, по которому хотим посчитать данные – «Хлеб».
      А в ячейке F3 (сумма) пишем формулу, которая посчитает все заказы Иванова на хлеб. Формула такая.
=СУММ((A2:A9=F2)*(B2:B9=F1)*C2:C9)
      В первых скобках формулы указан диапазон всех товаров, из которого нужно выбрать товар, написанный в ячейке F2 (хлеб).
      Во вторых скобках указан диапазон всех заказчиков, из которого нужно выбрать заказчика, написанного в ячейке F1 (Иванов).
      В третьих скобках суммируются выбранные данные.
НО, нажимаем не просто «Enter», а ТРИ кнопки: «Ctrl» + «Shift» + «Enter»Только тогда будет формула считать. Вокруг этой формулы появятся фигурные скобки. Так обозначаются формулы массива Excel. Подробнее о формулах массива, читайье в статье "Формулы массива Excel". Получилось так.
СЛОЖИТЬ ВЫБОРОЧНО ДАННЫЕ В EXCEL.Так можно выбирать и складывать любые данные из таблицы, любого диапазона.
      В Excel есть функции, которые считают не все ячейки, а выборочно, по условию, которое мы напишем в формуле. Например, посчитать сумму заказа определенного покупателя, итоги конкретного ученика, посчитать данные за определенную дату, т.д. Про одну из таких функций читайте в статье "Функция "СУММЕСЛИ" в Excel".
      В Excel можно написать ссылки на несколько листов в большой формуле быстро. Например, сложить данные отчетов, расположенных на разных листах. Подробнее, смотриет в статье "Ссылки в Excel на несколько листов сразу".