gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 106 гостей онлайн
Excel 2013. Посчитать стаж в Excel.

Посчитать стаж в Excel.

      Рассмотрим, как посчитать стаж в Excel. Один способ мы рассмотрели в статье «Как в Excel посчитать стаж». Здесь рассмотрим второй способ посчитать стаж в Excel. Но, тоже могут быть не точности с разницей в один, два дня, п. ч. разное число дней в месяцах, в годах.  
      Мы используем функцию «РАЗНДАТ» в Excel. Но, прикол в том, что это скрытая функция, ее в библиотеке функций нет. Поэтому будем писать формулу вручную.
 Итак, у нас такая таблица с датами.
В ячейке С2 пишем такую формулу.   =РАЗНДАТ(A2;B2;"y")   
Копируем формулу по столбцу. Как быстро скопировать формулу на весь столбец не перетаскиванием, смотрите в статье «Копирование в Excel» здесь.
Посчитались года. Получится так.
Чтобы посчитать месяцы, в ячейку D2 пишем такую формулу.    =РАЗНДАТ(A2;B2;"ym")
Копируем формулу по столбцу.
Чтобы посчитать дни, в ячейку Е2 пишем такую формулу.  =РАЗНДАТ(A2;B2;"md")
Получилось так.

Посчитать стаж в Excel.

      Как сложить стаж в Excel.
Осталось сложить периоды стажа.
      Чтобы посчитать года, в ячейке С7 пишем такую формулу.    =СУММ(C2:C6)+ЧАСТНОЕ(СУММ(D2:D6);12)
Эта формула считает года из столбца С и берет полные года (12 месяцев) из столбца D (месяцы).
      Чтобы посчитать месяцы, в ячейке D7 пишем такую формулу.    =ОСТАТ(СУММ(D2:D6);12)+ЧАСТНОЕ(СУММ(E2:E6);30)
Эта формула считает месяцы из столбца D и из столбца Е (дни), берет 30 дней за один месяц.
      Чтобы посчитать дни, в ячейке Е7 пишем такую формулу.   =ОСТАТ(СУММ(E2:E6);30)
Получится так.
Если в этом периоде будут пустые строки, то формулы все равно посчитают стаж. Например, так.Если не нужно считать отдельно стаж по отдельным периодам, достаточно посчитать общий стаж, то есть способ, посчитать такой стаж. Смотрите об этом способе статью "Как быстро посчитать стаж в Excel".
      Что означают буквы в формулах, смотрите в статье «Как посчитать возраст в Excel». Там же описано, как написать стаж в другом формате (например, 1 г. 11 м. 10 д.).
      В Excel можно сделать любой график, диаграмму, но есть способы, как сделать график ступеньками. Смотрите об этом  статью "Ступенчатый график в Excel".