gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 225 гостей онлайн
Excel 2013. Отрицательное время в Excel.

Отрицательное время в Excel.

      Какими способами посчитать время в Excel, какой установить формат, читайте в статье «Как посчитать время в Excel». Здесь разберем, что делать, если получилось отрицательное время и в ячейке появилась решетка.
      Если вычесть из меньшего времени большее, то получится отрицательное время в Excel (с минусом). Excel посчитает это время правильно и это отрицательное время будет участвовать в последующих расчетах. Но, в ячейке, вместо отрицательного времени будет стоять решетка. В таблице смотрим на ячейку B25. 
Отрицательное время в Excel.В ячейке В25 стоит такая формула.  =A25-A24  Результат - отрицательное время =-1:30.
      Это время будет участвовать в расчетах.
Смотрим ячейку В26. В ней стоит такая формула.   =A25+B25 Получилось 9:30.
      Чтобы убрать эту решетку, рассмотрим несколько способов, в зависимости от цели.
      Первый способ.
Можно умножить эту ячейку на «минус 1».  Получится положительное время.   В соседней ячейке напишем такую формулу.   =B25*(-1) Получится так.
Такое время (отрицательное, можно расположить в отдельном столбце и работать с ним.
     Второй способ.
В Excel время храниться в виде чисел. Счет времени ведется с 01 января 1900 г. Чтобы видно было отрицательное время, можно настроить в Excel систему дат с 02 января 1904 г.
      Переходим на закладку «Файл» (в Excel 2013) или нажимаем на знак «Office» (в Excel 2007). Выбираем функцию «Параметры» («Параметры Excel»). Нажимаем на функцию «Дополнительно». Внизу этого окна, в разделе «При пересчете этой книги» ставим галочку у слов «Использовать систему дат 1904». Нажимаем в диалоговом окне «Параметры Excel» кнопку «ОК».      Внимание!
Когда система дат будет изменена, могут возникать ошибки, если эта книга Excel содержит ссылки на другие книги.
      Третий способ.
Если нам нужно видеть получившееся отрицательное число, то можно посчитать по другой формуле.
      Нам нужно вычесть время из ячейки А25 (11:00:00) из времени в ячейке А24 (12:30:00). В ячейке С25 пишем такую формулу.
=ЕСЛИ(A25>=A24;0;"'-"&ТЕКСТ(A24-A25;"ч:мм"))
В ячейке С25 получилось отрицательное время – «-1:30:00». Смотрим таблицу, расположенную выше.
В ячейке С26 написали такую формулу. =ЕСЛИ(A26>=A25;0;"'-"&ТЕКСТ(A25-A26;"ч:мм"))
      Но, это время не будет считаться в формулах, п. ч. написано в текстовом формате.
      Чтобы посчитать отрицательное время, его можно разместить в отдельном столбце, сделать положительным по первому способу или считать ячейки с решеткой.
      Можно убрать знак «апостроф» из ячеек с отрицательным временем. Как это сделать, смотрите в статье «Преобразовать текст в дату Excel» тут. На время, все равно, не будет участвовать в расчетах.
      Как преобразовать положительное число в отрицательное или отрицательное число в положительное, читайте в статье "Положительное число в Excel сделать отрицательным и наоборот".
      В Excel можно записать отрицательное число, с использованием знака апостроф. Как посчитать такие числа, как убрать апостроф, оставив число отрицательным, т.д., читайте в статье "Как убрать апостроф в ячейке Excel".