gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 107 гостей онлайн
Excel 2013. В Excel по имени определить пол.

В Excel по имени определить пол.

      Можно в Excel определить пол по имени, по отчеству. При заполнении многих форм, списков приходится заполнять графу «Пол». Excel может автоматически определить пол и заполнить эту графу. Рассмотрим несколько формул.
      Первый способ.
      Определить пол по отчеству в Excel.
Принцип такой – русские женские отчества оканчиваются на окончание «-на», а мужские – на «-ч». Это мы используем в формуле.
 У нас такой список.
В ячейке В2 пишем такую формулу.  =ЕСЛИ(ПРАВСИМВ(A2)="ч";"м";"ж") Копируем формулу вниз по столбцу.
      Какими способами быстро скопировать формулу в длинном столбце, читайте в статье «Копирование в Excel».
Получилось так.
Определить пол по имени в Excel.Для лучшей видимости, для подсета, т.д., мы установили условное форматирование, чтобы шрифт с буквой «м» окрашивался в красный цвет. Как установить такое, смотрите в статье «Условное форматирование в Excel» тут
Как посчитать ячейки в цветным шрифтом, читайте в статье "Как посчитать цветные ячейки в Excel".
      Второй способ.
      Определить пол по имени в Excel.     
Если не все люди с русскими именами, то сделаем дополнительную таблицу, столбец. В этот столбец занесем все женские имена людей, которые есть в списке.
      Для дальнейшего удобства в работе с этим столбцом, сделаем его диапазон динамическим, чтобы при добавлении новых имен, не исправлять диапазон этого столбца в формуле. Как сделать динамический диапазон, смотрите в статье «Чтобы размер таблицы Excel менялся автоматически» здесь.
       У нас получилось такая страница со списком и столбцом с женскими именами.Столбцу с женскими именами присваиваем имя. Как – смотрите в статье «Присвоить имя в Excel ячейке, диапазону, формуле». Мы присвоили имя столбцу «Женские_имена».
      Теперь, в ячейке В2 пишем такую формулу.
      Внимание!
Это формула массива, стоит в фигурных скобках. Чтобы ввести формулу массива, после написания формулы нажимаем сочетание клавиш «Shift» + «Ctrl» + «Enter». Подробнее, читайте в статье «Формулы массива Excel» здесь.
Копируем формулу по столбцу. Получится так.
      Третий вариант.
      Определить пол по не русскому имени в Excel.   
 А что делать, если в писке есть не русские имена? 
      Предыдущие формулы будут все не русские имена, которых нет в столбце «Женские имена», определять, как мужские. Например, имя Алекс – это и женское имя, и мужское.
      Для более точного определения пола, пишем другую формулу. Для этого создаем столбец с мужскими именами. Присвоим ему имя «Мужск_имена».
     В ячейку D2 вводим такую формулу МАССИВА.
{=ЕСЛИ(СУММ(ЕСЛИОШИБКА(ПОИСК(Женские_имена;A2);0))>0;"ж";
ЕСЛИ(СУММ(ЕСЛИОШИБКА(ПОИСК(Мужск_имена;A2);0))>0;"м";"?"))}
Эта формула будет проверять в списке все имена по столбцам с женскими и мужскими именами и ставить знак вопроса, если этого имени нет в списке. Получится так.
Для удобства, мы условным форматированием окрасили знак вопроса.
      Четвертый вариант.
      Определить пол в Excel в сложных случаях.     
Если уж, совсем, мудреные имена, то можно выделить имена в отдельный столбец и определять пол по столбцу с именами.
      Как выделить имена из столбца с ФИО, смотрите в статье «Разделить текст Excel на несколько ячеек» тут.  
      В Excel можно заполнять столбцы датами, числами не последовательными, в через определенный промежуток. Например, заполнить столбец рабочими датами средины и конца месяца на год, чтобы отмечать дату оплаты, учебы, т.д. Подробнее о таком способе заполнения столбцов разными данными с разными промежутками, смотрите в статье "Как заполнить таблицу в Excel датами".

Продажа

Сайт продается!

Обращайтесь через "Обратную связь". 


 


Поиск по сайту