gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 122 гостей онлайн
Excel 2013. Как найти повторяющиеся значения в Excel.

Как найти повторяющиеся значения в Excel.

      Рассмотрим, как найти повторяющиеся значения в Excel, как выделить одинаковые значения словами, знаками, посчитать количество одинаковых значений, узнаем формулу для поиска одинаковых значений в Excel, т.д.
      В Excel   можно не только выделять и удалять дублирующие данные, но и работать с ними – посчитать дубли перед удалением, обозначить дубли словами, числами, знаками, найти повторяющиеся строки, состоящие из нескольких ячеек, т.д.
      Как выделить цветом одинаковые значения в Excel условным форматированием, читайте в статье "Условное форматирование в Excel".
Рассмотрим, как выделить и обозначить дубли. У нас такая таблица, в которой рассмотрим варианты работы с дублями.Дублирующие данные подкрасили условным форматированием. 
      Есть два варианта выделять ячейки с одинаковыми данными. Первый вариант, когда выделяются все ячейки с одинаковыми данными. Например, как в таблице (ячейки А5 и А8). Второй вариант – выделяем вторую и следующие ячейки в одинаковыми данными. А первую ячейку не выделять (выделить только ячейку А8). Будем рассматривать оба варианта.
      Первый способ.
      Как выделить повторяющиеся значения в Excel.
Нам нужно в соседнем столбце напротив данных ячеек написать слово «Да», если есть дубль, у ячеек с уникальными данными написать слово «Нет».
В столбце А устанавливаем фильтр. Как установить и работать с фильтром, смотрите в статье «Фильтр в Excel». В ячейке B2 пишем слово «Нет».
Как выделить одинаковые значения в Excel.Нажимаем два раза левой мышкой на зеленый квадратик в правом нижнем углу ячейки (на картинке обведен красным цветом). Слово скопируется вниз по столбцу до последней заполненной ячейки таблицы.
      Теперь в столбце A отфильтруем данные – «Фильтр по цвету ячейки». Можно по цвету шрифта, зависит от того, как выделены дубли в таблице.
В таблице остались две строки с дублями. В верхней ячейке отфильтрованного столбца B пишем слово «Да». Копируем по столбцу.Возвращаем фильтром все строки в таблице. Получилось так.
Мы подсветили ячейки со словом «Да» условным форматированием. Вместо слов, можно поставить числа. Получится так.Этот способ подходит, если данные в столбце A не меняются. Или, после изменения, повторить процедуру с обозначением дублей.
      Второй способ.
      Как выделить повторяющиеся ячейки в Excel.
Установим формулу в столбце D, чтобы автоматически писались слова. Формула такая.   =ЕСЛИ(СЧЁТЕСЛИ(A$5:A5;A5)>1;"Да";"Нет")
Копируем формулу по столбцу. Получится так.
      Обратите внимание, что такое выделение дублей, выделяет словом «Да» следующие повторы в ячейках, кроме первой ячейки.
Слова в этой формуле можно писать любые или числа, знаки. Например, в столбце E написали такую формулу.  =ЕСЛИ(СЧЁТЕСЛИ(A$5:A5;A5)>1;"Повторно";"Впервые")
В столбце F написали формулу.  =ЕСЛИ(СЧЁТЕСЛИ(A$5:A5;A5)>1;"+";"-")  Получилось так.      Идея.
Можно в таблице использовать формулу из столбца E или F, чтобы при заполнении соседнего столбца было сразу видно, есть дубли в столбце или нет. Например, создаем список фамилий в столбце А. В столбце B установили формулу.
=ЕСЛИ(СЧЁТЕСЛИ(A$5:A5;A5)>1;"+";"-")  Если в столбце В стоит «+», значит такую фамилию уже написали.
      Третий способ.
      Посчитать количество одинаковых значений Excel.
Нам нужно не только выделить повторы, но и вести их подсчет, написать в ячейке их количество.
В ячейке G5 пишем такую формулу. =ЕСЛИ(СЧЁТЕСЛИ(A$5:A$10;A5)>1;СЧЁТЕСЛИ(A$5:A5;A5);1)   Копируем по столбцу. Получился счетчик повторов. 
Изменим данные в столбце А для проверки. Получилось так.
Посчитать количество одинаковых значений Excel.Ещё один способ подсчета дублей описан в статье "Как удалить повторяющиеся значения в Excel".
      Как посчитать данные в ячейках с дублями, а, затем, удалить их, смотрите в статье «Как сложить и удалить ячейки с дублями в Excel» здесь.
      Четвертый способ.
      Формула для поиска одинаковых значений в Excel.
      Нам нужно выделить дубли формулой в условном форматировании. Выделяем ячейки. Вызываем диалоговое окно условного форматирования. Выбираем функцию «Использовать формулу для определения форматируемых ячеек».
В строке «Форматировать формулу для определения форматируемых ячеек» пишем такую формулу.  =СЧЁТЕСЛИ($A:$A;A5)>1  Устанавливаем формат, если нужно выбрать другой цвет ячеек или шрифта.Формула для поиска одинаковых значений в Excel.Нажимаем «ОК». Все ячейки с повторяющимися данными окрасились.
      Идея.
Можно в условном форматировании установить белый цвет заливки и шрифта. Получится так.
Первые ячейки остались видны, а последующие повторы не видны. При изменении данных в первом столбце меняются и пустые ячейки, в зависимости от того, где находятся дубли.
      Пятый способ.
      Как найти повторяющиеся строки в Excel.
Нужно сравнить и выделить данные по трем столбцам сразу. У нас такая таблица.Как найти повторяющиеся строки в Excel.В столбцах A, B, C стоят фамилии, имена и отчества. Чтобы сравнить сразу по трем столбцам, нужно соединить данные трех столбцов в одной ячейке. В ячейке D15 пишем формулу, используя функцию «СЦЕПИТЬ» в Excel. =СЦЕПИТЬ(A15;" ";B15;" ";C15) 
      Про функцию «СЦЕПИТЬ» читайте в статье «Функция «СЦЕПИТЬ» в Excel».
Копируем формулу по столбцу.  Теперь выделяем дубли любым способом.
      Как посчитать в Excel рабочие дни, прибавить к дате дни, т.д., смотрите в статье "Как посчитать рабочие дни в Excel".

Продажа

Сайт продается!

Обращайтесь через "Обратную связь". 


 


Поиск по сайту