gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 287 гостей онлайн
Excel 2013. Формула округления в Excel.

Формула округления в Excel.

      Округление в Excel можно проводить не только по правилам математики. Можно настроить округление Excel в большую сторону, в меньшую сторону, округлить до целого числа, до десятков, тысяч, до определенного числа, т.д.
      Какими способами округлить в Excel числа, смотрите в статье «Округление в Excel». Здесь разберем конкретные примеры использования функций округления. Можно написать разные формулы округления в Excel.
      Первый пример.
      Округлить в Excel цифры до конкретного числа.
Нам нужно установить цену товара со скидкой не меньше цены себестоимости.
У нас такая таблица с ценами.
В этой таблице видно, что у некоторых товаров цена со скидкой ниже цены себестоимости. Нам нужно у этого товара поднять цену скидки до цены себестоимости.
       В ячейке Е2 пишем такую формулу. =ЕСЛИ(ОКРВВЕРХ(СУММ(C2/100*90);1)<=B2;B2;ОКРВВЕРХ(СУММ(C2/100*90);1))
Копируем формулу вниз по столбцу.  Какими способами быстро скопировать формулу по столбцу, смотрите в статье «Копирование в Excel» здесь.
      Получилось так.
Округлить в Excel до конкретного числа.      Второй пример.
      Округлить в Excel числа до, не менее конкретной цифры.
Для того, чтобы установить цену по скидке не ниже цены себестоимости, можно применить такую формулу.
=МАКС(ОКРВВЕРХ(СУММ(C2*0,9);1);B2)
Копируем формулу вниз по столбцу. Получилось так. Смотрите столбец F.      Третий вариант.
      Формула округления в Excel до определенного числа.
Нам нужно округлить числа так:
   числа до 40 – поставить в ячейке число «40»;
   числа от 40 до 50 – поставить в ячейке число «50»;
   числа больше 50 – поставить в ячейке число «100».
В ячейке С2 напишем такую формулу. =ЕСЛИ(B2<=40;40;ЕСЛИ(B2<=50;50;ЕСЛИ(B2>50;100;0)))
Скопируем формулу вниз по столбцу. Получится так.
 Еще примеры разного не стандартного округления чисел в Excel, смотрите в статье "Округление Excel в большую сторону".