gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 216 гостей онлайн
Excel 2013. Посчитать количество дней недели между датами в Excel.

Посчитать количество дней недели между датами в Excel.

      Рассмотрим, как в Excel посчитать количество воскресений между датами, или суббот, или любого другого дня недели.
Как производить расчеты дат, смотрите в статье «Работа с датами в Excel» здесь.
      Обратите внимание!
В конце статьи в разделе «Другие статьи по этой теме» есть много статей с описанием разных расчетов дат, стажа, возраста, отпуска, времени, как определить день недели по дате, т.д.
      Итак, посчитаем количество воскресений между датами в Excel. Сделаем такую таблицу.День недели ставим числом от 1 – понедельник, до 7 – воскресенье.
      Мы, в примере, поставили цифру 7 – воскресенье. В ячейке D1 пишем такую формулу.
=СУММПРОИЗВ(СУММЕСЛИ(C2;ДЕНЬНЕД(СТРОКА(ИНДЕКС(A:A;A$2):ИНДЕКС(B:B;B$2))
;2)))/C2
      Внимание!
Когда будем писать формулу, то нужно обратить внимание, по какому принципу будут считаться дни недели. Например, понедельник – это 1 или 2?  Когда дописывали формулу, появилось такое окно. Мы выбрали второй порядок счета дней недели. Два раза нажали мышкой в этом окне. Цифра 2 появилась в формуле.
Дописали формулу, нажали «Enter». Получилось пять воскресений в ноябре. 
Посчитать количество дней недели между датами в Excel.Поставим в ячейке С2 цифру 6 – посчитаем, сколько суббот в ноябре месяце 2015 года. Получилось четыре субботы.Так можно посчитать любой день недели в любом периоде дат.
Можно в Excel по дате определить день недели. Смотрите об этом в статье "День недели по дате в Excel" тут.
      Как посчитать только рабочие дни между датами, смотрите в статье «Как посчитать рабочие дни в Excel».
Как посчитать количество календарных дней с выходными, но без праздников (например, отпуск), читайте в статье «Количество дней между датами без праздников в Excel» здесь.
      Как посчитать остаток дней в определенном периоде, например, остаток неиспользованных дней отпуска, смотрите в статье "Посчитать остаток дней в периоде в Excel".