gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 533 гостей онлайн
Excel 2013. Как объединить данные теста в ячейках в Excel.

Как объединить данные теста в ячейках в Excel.

      Как создать тест в Excel, смотрите в статье «Как сделать тест в Excel». Если результат в тестах стоит в виде чисел, баллов, то можно сложить эти числа. Какими способами – смотрите в статье «Сумма в Excel».
      Если результат стоит словами, знаками, то, тоже, поможет формула. Здесь рассмотрим способ объединения таких данных.
      Объединить данные в ячейках в Excel.
У нас два листа с результатами тестов.
Нам нужно объединить результаты этих тестов.
      Первый способ.
      Как посчитать количество ячеек в Excel.
Можно узнать результат по каждому тесту, затем, сложить эти результаты.
Мы посчитаем количество ячеек с правильным ответом (со знаком «+»). В ячейке В8 пишем такую формулу.  =СЧЁТЕСЛИ(B3:B7;"+")
Этой формулой мы говорим Excel, чтобы он считал ячейки, только, со знаком «+».
     Если таблица длинная, то диапазону ячеек столбца B в таблице можно присвоить имя. Мы, для примера, присвоим имя «Сумма2». Формула в ячейке С8 получится такая.  =СЧЁТЕСЛИ(Сумма2;"+")
      В ячейке Е8 пишем формулу =СЧЁТЕСЛИ(E3:E7;"=+")
Получится так.
Если нужно узнать количество, не только правильных, но и неправильных ответов, то в другой ячейке можно написать такую же формулу, изменив в ней знак «+» на знак «-». Подробнее о функции «СЧЁТЕСЛИ» читайте в статье «Функция «СЧЁТЕСЛИ» в Excel».
В ячейку G6 написали формулу сложения.
      Второй вариант.
Можно перевести знаки «+» и «-» в баллы. Не только знаки, но и слова.
Для этого в ячейке С3 пишем такую формулу. =ЕСЛИ(B3="+";"1";"0")
      Этой формулой мы говорим Excel, что, если в ячейке В3 стоит «+», то в ячейку С3 поставить цифру «1» (можно поставить любое число баллов). Если в ячейке В3 стоит знак «-», то поставить «0» (нуль) в ячейке С3.
Подобную формулу пишем в ячейке F3.  =ЕСЛИ(E3="+";"1";"0")
Про функцию "ЕСЛИ" подробнее, читайте в статье "Функция "ЕСЛИ" в Excel".
      Такими же формулами, но поменяв в них «+» на «-», можно посчитать количество отрицательных баллов.
Копируем формулы вниз по столбцам. Как быстро скопировать формулу в большой таблице, смотрите в статье «Копирование в Excel».
Получится так.
Теперь, осталось установить формулы сложения в нужных ячейках – по строкам или по столбцам, т.д.  Получится так.В ячейках столбца G стоят простые формулы сложения. =C3+F3
      Мы установили условное форматирование в столбцах с результатами теста, чтобы ошибки высвечивались красным цветом или шрифтом. Установить можно любой цвет, шрифт, границы ячейки, т.д.
      Как установить такое условное форматирование, читайте в статье «Условное форматирование в Excel».
      Можно установить одну большую формулу, чтобы она считала все «+» (плюсы) по всем строкам во всех анкетах сразу.
В этом случае, в ячейке G6 пишем такую формулу. =СЧЁТЕСЛИ(B3:B7;"+")+СЧЁТЕСЛИ(E3:E7;"+")
      Третий способ.
      Объединить таблицы в Excel.
Если названия столбцов, строк одинаковые, то можно применить консолидацию. Смотрите об этом статью «Как объединить таблицы в Excel».
      Четвертый способ.
Можно объединить сводные таблицы в одну. Об этом способе читайте статью «Сводная таблица в Excel из нескольких таблиц».
      В Excel можно округлять числа не только по правилам математике, но и, до нужной цифры, или, чтобы последняя цифра в числе была 9 или 99, или 0,5, не меньше конкретного числа, т.д. Подробнее о нестандартном округлении чисел, смотрите в статье "Формула округления в Excel".

Поиск по сайту

Подписка на рассылку

Подписывайтесь на рассылку и получайте актуальную информацию об обновлениях на ресурсе.