gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 92 гостей онлайн
Диапазон таблицы Excel. Суммирование ячеек в Excel по условию.

Суммирование ячеек в Excel по условию.

      Рассмотрим, как проводить суммирование в Excel по условиям. Складывать в Excel можно, не только, по столбцам и строкам, но и выбирать для сложения данные из таблицы по разным условиям.
      Как установить простое условие для подсчета данных, смотрите в статье "Функция "ЕСЛИ" в Excel".
      Здесь рассмотрим функцию «СУММЕСЛИМН» в Excel, которая суммирует числа, удовлетворяющие нескольким условиям, выбирает определенные данные для сложения по нескольким условиям. Можно указать до 127 условий.
      Есть еще функция "СУММЕСЛИ", но в ней можно указать одно условие. Смотрите статью "Функция "СУММЕСЛИ" в Excel" тут.
Итак, у нас такая таблица.
Нам нужно посчитать сумму проданных яблок, которые продал менеджер Васечкин покупателю Иванову.
В ячейку F5 устанавливаем формулу.
      На закладке «Формулы» в разделе «Библиотека функций» выбираем «Математические». В появившемся списке нажимаем на функцию «СУММЕСЛИМН». Появится такое окно.В этом окне строки для одного диапазона и одного условия. Но, можно написать до 127 условий.
      Итак, заполняем диалоговое окно так.
В строке «Диапазон суммирования» пишем диапазон D2-D8 – это столбец с суммами покупок.
В строке «Диапазон условия1» пишем диапазон столбца с менеджерами. У нас - B2-B8.
      Обратите внимание.
Когда мы поставили курсор в эту строку, автоматически появилась новая строка для условий. Если условий много, то появляется полоса прокрутки, с помощью которой, переходим в следующие окна условий.
В строке «Условие1» пишем фамилию менеджера. Мы написали – Васечкин.
В строке «Диапазон условия2» пишем диапазон столбца покупателей – А2:А8.
В строке «Условие2» написали фамилию покупателя – Иванов.
      Двигаем поле условий полосой прокрутки, пишем следующее условие.
В строке «Диапазон условий3» пишем диапазон С2:С8.
В строке «Условие3» пишем – «яблоки».Нажимаем «ОК». Получился такой результат.
Суммирование ячеек в Excel по условию.Формула в ячейке А5 такая.
=СУММЕСЛИМН(D2:D8;B2:B8;"Васечкин";A2:A8;"Иванов";C2:C8;"яблоки")
      Если нужно посчитать на какую сумму продал менеджер Васечкин всего разных фруктов Иванову, то напишем такую формулу с двумя условиями.
=СУММЕСЛИМН(D2:D8;B2:B8;"Васечкин";A2:A8;"Иванов")
      Если нужно посчитать сколько продали яблок Иванову менеджеры Васечкин и Сергеева, то формулу напишем так.
=СУММЕСЛИМН(D2:D8;B2:B8;"Васечкин";A2:A8;"Иванов";C2:C8;"яблоки")+
СУММЕСЛИМН(D2:D8;B2:B8;"Сергеева";A2:A8;"Иванов";C2:C8;"яблоки")
      Пишем эту формулу так. Сначала вставляем функцию «СУММЕСЛИМН» по Васечкину. Нажимаем «ОК». В строке формул в конце формулы ставим знак «+» и вставляем функцию «СУММЕСЛИМН» по Сергеевой. Получается, мы сложили функции отдельно по каждому менеджеру.
      Внимание!
В условиях этой функции «СУММЕСЛИМН» количество ячеек диапазона суммирования и количество ячеек диапазона условий должно быть одинаковое. Например, все диапазоны с 3 по 8 ячейки. Если будет диапазон суммирования с 3 по 10 ячейки. А диапазон условия с 3 по 8, то формула посчитает не верно. Это нужно учитывать при установлении функции «СУММЕСЛИМН».
     Есть еще одна функция в Excel, которая считает выборочно по условию. В ней можно указывать разной длины диапазоны, но условие можно указать только одно. Подробнее о применении функции «СУММЕСЛИ», о символах, которые можно вставить в критерий функции, смотрите в статье «Как посчитать в Excel ячейки в определенных строках».
     Еще много примеров использования функции "СУММЕСЛИМН", смотрите в статье "Примеры функции "СУММЕСЛИМН" в Excel".