gototopgototop

Материалы Excel

Сейчас на сайте

Сейчас 254 гостей онлайн
Диапазон таблицы Excel. Автонумерация в Excel.

Автонумерация в Excel.

      Рассмотрим, как сделать порядковый номер в Excel, как сделать автонумерацию в Excel. Автонумерацию в Excel можно настроить с помощью формулы. Рассмотрим несколько вариантов.
      Первый вариант.
      Как сделать порядковый номер в Excel.
В ячейке А1 пишем цифру 1. В ячейке А2 пишем формулу. =А1+1 Копируем формулу вниз по столбцу. Этот способ не удобен, если из таблицы удаляют строки.
      Второй способ.
      Как сделать в Excel номер по порядку.
У нас такая таблица.
В ячейке А2 пишем такую формулу.   =СЧЁТЗ($B$2:B2)
      Обратите внимание!
Первая ссылка на первую ячейку таблицы – абсолютная ($B$2). Подробнее о разных ссылках читайте в статье «Относительные и абсолютные ссылки в Excel».
Копируем формулу вниз по столбцу. Получилось так.
Как сделать порядковый номер в Excel.Если у вас пустая таблица, то порядковый номер строк будет «0». Как только вы заполните ячейку из столбца В, то появится цифра.Если вы протяните в заполненной таблице формулу на незаполненные ячейки, то будет повторяться последний номер по порядку.При заполнении пустых ячеек, номер ячейки изменится на следующий по порядку. Это не совсем красиво. Но, как всегда, есть выход.
      Выделяем ячейки столбца А. На закладке "Главная" в разделе "Стили" нажимаем на кнопку "Условное форматирование", выбираем функцию "Создать правила". Появившееся окно заполняем так.Ячейка D2 - это отдельная ячейка, которая всегда будет пустой. Её можно сделать далеко внизу таблицы, т.д. 
Установили цвет шрифта - "белый". Нажимаем "ОК". Получится так.
Если ячейка в столбце B будет пустой, то порядковый номер напротив этой ячейки не будет виден. Номера остаются по порядку.
Так можно нумировать список дат.
Как и где ещё можно применить условное форматирование, смотрите в статье "Условное форматирование в Excel".
      Третий способ.
      Автонумерация в Excel.
Чтобы порядковый номер всегда был верным, не путался среди пустых ячеек, напишем такую формулу.  =ЕСЛИ(ЕПУСТО(B2);"";СЧЁТЗ($B$2:B2))
Копируем формулу по столбцу. Получилось так.
Автонумерация в Excel.      Ещё один способ, как настроить автоматическун нумерацию строк по прорядку, чтобы не сбивалась при работе фильра, смотрите в статье "Порядковый номер строк по порядку после фильтра в Excel".
      Таблица Excel до того умная, что может считать без формул. Смотрите об этом статью "Как быстро посчитать в Excel".